.NET Core + EF 报nuget包版本冲突错误

错误信息如下:

错误 NU1107 Microsoft.EntityFrameworkCore 中检测到版本冲突。直接安装/引用 Microsoft.EntityFrameworkCore 2.2.4 到项目 CoreWeb 可解决此问题。

NewsPublish -> NewsPublish.Service -> Microsoft.EntityFrameworkCore (>= 2.2.4)
NewsPublish -> Microsoft.AspNetCore.App 2.1.1 -> Microsoft.EntityFrameworkCore (>= 2.1.1 && < 2.2.0).

问题出现原因是:nuget包版本不兼容

升级包,发现无法升级,然后查原因是.net Core版本问题,

升级版本至2.2,并在项目上添加目标框架为2.2,问题解决。